soundjack.exe quits – problem

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • (@)


    a member of my group tries to start the soundjack.exe on Windows. The command window opens and many entries about “ are shown, also a entry: “Please uninstall the tool manycam if present”. Such a software is not installed on this device. This happens in 1-2 seconds, then the window closes. Does anyone has an idea where this problems comes from?


    Best regards,


    I see a very similar set of entries on the Soundjack command prompt window, but it does connect after a fashion. I have tried port forwarding, but this seems to have had no effect whatsoever. Can anyone suggest how to solve this problem please?


    Please check the FAQ – the websocket is not created and several potential reasons for this are being described in there.


    P.S.: It also looks like you’re using an outdated version of the SJC. Is this the latest SJC210106 ?


    I have the latest version. I tried the tips in the FAQ, and have amended the NAT/Port forwarding settings on my router. I do have some connection, but I have similar error messages to the OP, and the connection is of very poor quality. Any other suggestions please?


    I’m not sure if it would help, but create a new user (only for SoundJack) and log in into that user with no other active login at the same time. Optimally reboot with no user logged in (even not in background) and log into the SoundJack user account. The only thing you need there is the SJC which you might need to download again and access to a web browser for SoundJack.
    If you are lucky, the error message is gone.

    The problem might be that another application or background demon already uses the port numbers that SoundJack wants to use and that leads to the problem. One known application which does this is manycam, therefor the hint to deinstall manycam if it is installed. But any other application can grab the port too, not only manycam. In this case unfortunately you are on your own to detect and remove the application that blocks the ports that SoundJack need.

    It might be a firewall that blocks, so one of the first things should be to check if SoundJack has full access (or at least access to the needed ports for SoundJack).


    I have enabled websockets on my machine (Windows 10). I have also checked the firewall, which is allowing Soundjack through. I have also enabled NAT/port forwarding. If it helps, the number in brackets after “UDP Port 2” is “181”. What is the significance of this?


    Thanks. this information does help.

    If there is an 8 (specially in the middle) it means that port forwarding on the router (!) does not work to the interface selected in the stage of soundjack.
    A typical error is that the WLAN IP-address is selected instead of the LAN IP-address. By default SoundJack uses the smallest IP-address available, but you can select any other connected network interface from the menu on the stage.
    You might be able to connect to other users with (181), but I’m not sure if this really works.

    With (181) you should be able to participate in server-based setups and check your own sound with mirrors, but you cannot use p2p-connections to other users unless they have no 8 in that three digit number (usually all the the digits are between 1 and 3 for those users). Without an 8 in the three-digit-number the port forwarding works and at least one side of a connection needs this kind of port forwarding.

    If you have made a port forwarding in the router it is either the wrong port (wrong number or TCP instead of UDP) or the forwarding address is not the selected IP-address on the stage.

    If the IP-addresses are not the same it could have a simple reason: you selected the dynamic WLAN address that is different than your forwarding address.
    Or more complicated: the LAN address might be changing due to DHCP and is no longer the IP-address you forwarded to or you have a static address that is not the same as the forwarding address of the router.

    If you use a static address, make sure it is outside of the range of the DHCP addresses that the DHCP server (usually your router) uses. It is a good idea to use a lower address, but stay away from one to three as the last number in the IPv4-address for your computer and the port forwarding (they are often used for the router).

    And don’t use the LAN interface outside of home, because it won’t work in most cases and can cause network blocking in a different network. But usually you only use WLAN out of home and this still works with DHCP, so that will continue to work in different networks than your home network.

    I know this is a bit technical, but these are the pitfalls in port forwarding.

    Why is this so complicated:

    Most IPv4 home connections only have a single address, not a network of addresses. The router enables to distribute access to the internet, but from outside this is still a single address. So any port numbers are present only once. If you want to get UDP (!) packets (that do not have a connection, it’s more like a postcard) on an internal computer you must explicitly forward that port to the internal IP-address of your computer (even if there is no other device in the network).

    Often routers want an IP-address as the destination for the port forwarding, but DHCP, which is usually enabled by default to be able to use the computer in any network, can give different addresses to your computer at different times.
    There are two solutions, one is to use a static address which typically does not work if you use the interface with the static address in a different network, and the other is to bind the port forwarded IP-address to the MAC-address (this is the hardware address of your network interface) in the DHCP server (of your router).

    Since this might differ from router to router to setup if it is available at all, I cannot explain to you how to do that. I explained it for the german FritzBox (in my german documentation in user docs) which is commonly used in Germany, but cannot do that for all routers and since it was very time consuming to write that, I won’t translate it (which might not make sense if that router not used outside of Germany).
    Also the screen shots are from a german user surface and would needed to made new (and might not help with a non-english user surface in other countries).

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.