Port Forwarding stopped working

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • (@joeyjazztoronto)

    I had Port Forwarding working (i.e. #111 shows on stage), but now it’s stopped working.

    Then I noticed that my iMac had changed its Local IP from 192.168.0.10 to 192.168.0.13.
    So I changed that in router’s Port Forwarding rule.
    But it doesn’t help.

    In between this working and then not working, I also upgraded my OS to Big Sur.
    I notice on the Downloads page that SJC is compatible up OS 10.5.
    Could that be the problem?
    Can it not handle OS 11?

    Kinda at my wit’s end about this.
    I hate having to do all this troubleshooting all the time.

    What else could/would cause Port Forwarding to just stop working after it’s already been set up properly?

    Joey

    (@jgspix)

    IF your IP-address is defined by DHCP, it is possible that after some longer timeout a different IP-address could be assigned to your computer.
    In that case check if your router can make a fixed IP-address assignment to your computer which is often presented by name but the assignment is made to the MAC-address of your network interface which is a worldwide unique address.

    It might also be that on the SOundJack stage for some reason the IP-address of your WLAN interface is selected. In that case select the IP-address of your LAN-interface there. If it is not present check the LAN connection and reload the stage. Then select the LAN-IP-address on the reloaded stage.

    I have no experience beyond Mac OS 10.14, so if it is a BigSur-problem someone else need to help you.
    It would be nice for others reading this if you could write back here if my hints (and which one) helped with your problem.

    (@joeyjazztoronto)

    Thanks.

    The issue yesterday was resolved.
    What had happened was that my ISP had changed my IP number and when I went to edit my Port Forwarding Rules I accidentally entered in 50500 for the ports when it should have been 50050.
    After I fixed that, everything was fine.

    But today, my ISP went and did it again.
    So I edited the PF rules again, with the correct port numbers and the correct IP number, but I’m still getting (181).
    I even went and far as setting up a static IP.
    But I’m still seeing 181.
    Funny thing is, when I try to connect to my own feed via WAN, it works!
    I thought this type of connection only worked if PF was set up properly?
    Isn’t that the main way to check if PF IS working?

    So now I’m confused again.

    (@jgspix)

    Its a special feature of your router if you can connect to the WAN-address of your router. And since it is a feature of your router it might not really go that far until it is reflected back.
    This is not possible with my setup, which is rather special going through two routers in series, one to separate VoIP for my house-PBX and forward everything else and one to do the real router job (I wanted to keep that router due to VPN functionality).

    So the only way to check if my port forwarding works is the three digit number after UDP2-port (my port forwarding works with 321, without port forwarding it is 381).

    I do not understand why changing your provider IP-address breaks the port forwarding. I’m pretty sure you only get a single IP-address from your provider. All routers I know only need an internal (LAN-)address for the port forwarding, since the router IP-address is defined by your provider. But maybe it is a misunderstanding?
    What you might mean is that your computer on the LAN gets a different IP-address every time you switch it on (or after a longer switch-off-period). This can happen if you use DHCP (or automatic) for the method to get an IP-address for your computer.
    Static IP would solve that, but then the static IP must be out of the range of the DHCP-distributed IP-addresses. Check the DHCP settings of your router for that. But then this network interface won’t work in a different network and may even cause network problems there.
    The better way is to identify the DHCP-IP-address with the MAC-address of the network interface of your computer. Then it is still DHCP, which works in any network, but you still get the same IP-address in your own LAN. Since every router is different, you have to find yourself how to do it with your router.

    Maybe that helps a bit.

    (@jgspix)

    It seems that currently (2021-02-24 12:00) there is a problem with SoundJack.

    My entry is now 381 instead of 321 and I have problems as if the port forwarding does not work too, but anything is correctly configured on my side.
    After a reboot of all routers, switches and the SoundJack computer I don’t get any connected users on the stage, but the arrows and number of entries is displayed. Left column is present as well as the chat window.
    Alex is informed, so we need to wait and check later if it works again.

    I will put a note here as soon it works again on my side.

    (@jgspix)

    The entries on the right side are back.

    Alex announced that the port forwarding should be solved in about 24 hours.
    I will check it tomorrow.

    (@jgspix)

    I missed that since Wednesday there is a new SJC-version (210224). With this version the (321) NAT indicator came back for me. Might bring back your former NAT indicator too.
    This version works very well, can use a network buffer of 128 now (with some artifacts, but not too often), even 64 if my machine would be faster.

    Try with this new version and in general, if something doesn’t work as expected, have look at the download page if there is a newer version available and if not, download anyway, it might have been updated with minor corrections. At least worth a try.

    (@brickivyconifer)

    In the public chat room I read this notice.:

    jazzalex
    04:20AM
    SJC210224 had a problem with receiver levelmeters – just fixed it and uploaded it under the same name.

    So if you upgraded on 24-Feb or 25-Feb, you should probably upgrade again.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Who’s Online
Profile picture of Chris Welles
Profile picture of Dennis Paproski
Profile picture of Anshul Saxena
Profile picture of Daniel Williams
Profile picture of Michael Berliner
Profile picture of James Saltman
Profile picture of Bo Winiker
Profile picture of MAURO CATALANO-f
Profile picture of Covenant FMB08