Linux error

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • (@)

    Hi, i’m currently trying to use the SJC with the Behringer UMC202HD, but i’m having issues with the Linux version of the SJC.
    When i use a Windows machine (+ asio4all driver) or the Symonics’ Fastmusic Box i can just plug in the UMC202HD and select it in the stage area. But if i try my Laptop the setup is not working. Im running Fedora 31 with kernel version 5.8.18 and KDE v5.18.5/Qt v5.13.2 and when i select the UMC202HD as the input device i get the error message
    Expression ‘parameters->channelCount <= maxChans’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 1513
    Expression ‘ValidateParameters( inputParameters, hostApi, StreamDirection_In )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2813
    I tried to use qjackctl and i got it to work but i’m having dropouts with settings 64/2 and clicks with higher settings. How would i go about debugging this problem? I cannot use the other systems as they are already in use..


    I cannot help with your Linux problem, but for the UMC202HD there should be a native ASIO driver downloadable at Behringers site (part of the lowest entry for drivers in the software selection menu, you need to scroll down there to find it).
    I also read somewhere that a realtime version of Linux might work better than more general distributions, but I never tried SoundJack myself on Linux.


    I got it already working on Windows with the mentioned driver and i got it to work on the FMB (which actually is a Pi with a realtime version of linux) but i’m trying to get a working setup on my/other’s linux machine because i cannot afford to buy several Pi’s and FMB licences or tell my band to install Windows.


    If needed, i could provide a stacktrace or similar


    I suggest installing Cadence to run Jack (instead of qJackCtl).

    It’s available here:


Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.