Boeuf franco-allemand / French-German jam session: sound problem

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • (@mk1967)

    Yesterday afternoon we – a French piano player and me – have tried to set up a stage for jamming, pour un boeuf franco-allemand en duo.

    She was able to hear me playing while I couldn’t hear anything of her but scratches and very short fragments of sound. She tried to experiment with different buffer settings etc. but it didn’t really help.

    We wondered if this was a problem of her sound setting (we were both connected using LAN cables, but for me it sounded like the results of my very first soundjack experiments using WiFi: hopeless) or a problem of my buffer settings – OR (!) if it’s just a (server?) problem when you set up a soundjack connection between musicians in two different countries like France and Germany? The distance between us was more than 1000 kilometres…

    She was on Windows 10 and I was on Linux (LibraZiK 3 studio, based on Debian 10). I used Chromium web browser – I forgot to ask her if she used Edge or Firefox or Chrome. (She did not use Safari.)

    Thanks a lot in advance for any ideas and hints ­čÖé
    Michael

    (@jgspix)

    The server is only involved to make the connection in p2p-mode, then the server is out for the connection (except for stage visuals and the public chatroom. You can try to connect both to a public server (N├╝rnberg or T├╝bingen), to check if it works that way.

    I had no problems using Edge or Firefox under Windows 10 with SoundJack, not even with Chromium (stripped down Chrome without Google).

    If something doesn’t work well, start with a network buffer of 512.
    The sample buffer is an individual setting on both sides and only has influence on that machines sound. It should be checked with local sound first before making a connection. Usually values between 512 and 128 should be possible, often also 64 is possible, 32 only with very fast machines and few connections.

    Another source of error might be a wrong sampling rate. Usually SoundJack sets the sampling rate for the interface, ,but sometimes it might fail. The sample rate must be 48000 Hz (48 KHz) for SoundJack. If you use Jack, the buffer size in Jack must be the same as the sample buffer size in SoundJack. So better avoid using Jack if something goes wrong.

    An often working buffer setting is 128/256/2 (sample/network/jitter), on my rather old computer (C2D 2.5GHz) the limit is 64/128/1, but keep in mind, what works with only one participant might no longer work with several.

    The level indicators take a lot of processing power (more than the old VU-meters). So Alex decided that for slower machines it makes sense to deactivate them (there is an explanation about the level meters in the support forum). That might help too.

    Good luck next time!

    (@jgspix)

    Two different countries are no problem. The IP-protocol doesn’t know countries.

    But I had a problem with mirored sound under Linux with the sound buffer at 64 and network buffer at 128. every few seconds I got at least a second dropout with some garbled sound. After changing back to Sound Buffer 128 and network buffer at 256 it worked.
    But my machine is old (i5, 1st gen.).

    You might also want to disable the level meters after you have leveled in yourself. That reduces the CPU load by a substantial amount.

    (@mk1967)

    Thank you J├Ârg (and please excuse my late reply, I was busy with travelling). Good ideas ! For my very old machines as well ;-).
    We will try it.

    Michael

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Who’s Online
Profile picture of dagloopa
Profile picture of Emma Jones
Profile picture of Ellen Lee