Reply To: soundjack.exe quits – qt.network.ssl problem

(@jgspix)

Thanks. this information does help.

If there is an 8 (specially in the middle) it means that port forwarding on the router (!) does not work to the interface selected in the stage of soundjack.
A typical error is that the WLAN IP-address is selected instead of the LAN IP-address. By default SoundJack uses the smallest IP-address available, but you can select any other connected network interface from the menu on the stage.
You might be able to connect to other users with (181), but I’m not sure if this really works.

With (181) you should be able to participate in server-based setups and check your own sound with mirrors, but you cannot use p2p-connections to other users unless they have no 8 in that three digit number (usually all the the digits are between 1 and 3 for those users). Without an 8 in the three-digit-number the port forwarding works and at least one side of a connection needs this kind of port forwarding.

If you have made a port forwarding in the router it is either the wrong port (wrong number or TCP instead of UDP) or the forwarding address is not the selected IP-address on the stage.

If the IP-addresses are not the same it could have a simple reason: you selected the dynamic WLAN address that is different than your forwarding address.
Or more complicated: the LAN address might be changing due to DHCP and is no longer the IP-address you forwarded to or you have a static address that is not the same as the forwarding address of the router.

If you use a static address, make sure it is outside of the range of the DHCP addresses that the DHCP server (usually your router) uses. It is a good idea to use a lower address, but stay away from one to three as the last number in the IPv4-address for your computer and the port forwarding (they are often used for the router).

And don’t use the LAN interface outside of home, because it won’t work in most cases and can cause network blocking in a different network. But usually you only use WLAN out of home and this still works with DHCP, so that will continue to work in different networks than your home network.

I know this is a bit technical, but these are the pitfalls in port forwarding.

Why is this so complicated:

Most IPv4 home connections only have a single address, not a network of addresses. The router enables to distribute access to the internet, but from outside this is still a single address. So any port numbers are present only once. If you want to get UDP (!) packets (that do not have a connection, it’s more like a postcard) on an internal computer you must explicitly forward that port to the internal IP-address of your computer (even if there is no other device in the network).

Often routers want an IP-address as the destination for the port forwarding, but DHCP, which is usually enabled by default to be able to use the computer in any network, can give different addresses to your computer at different times.
There are two solutions, one is to use a static address which typically does not work if you use the interface with the static address in a different network, and the other is to bind the port forwarded IP-address to the MAC-address (this is the hardware address of your network interface) in the DHCP server (of your router).

Since this might differ from router to router to setup if it is available at all, I cannot explain to you how to do that. I explained it for the german FritzBox (in my german documentation in user docs) which is commonly used in Germany, but cannot do that for all routers and since it was very time consuming to write that, I won’t translate it (which might not make sense if that router not used outside of Germany).
Also the screen shots are from a german user surface and would needed to made new (and might not help with a non-english user surface in other countries).

Who’s Online
Profile picture of dagloopa
Profile picture of Emma Jones